aboutsummaryrefslogtreecommitdiffstats
path: root/host/CMakeLists.txt
diff options
context:
space:
mode:
authorMartin Braun <martin.braun@ettus.com>2015-04-15 15:51:25 -0500
committerMartin Braun <martin.braun@ettus.com>2015-04-15 15:51:25 -0500
commit3e3e236acb3803d336d82ea36e6a88e50bf30f5c (patch)
tree4ccb3634b8fa99002bf7a2ae13f18339ccf201da /host/CMakeLists.txt
parent1cb81aaf0e15f33b4a27d01ad8ea58206f8d9e31 (diff)
downloaduhd-3e3e236acb3803d336d82ea36e6a88e50bf30f5c.tar.gz
uhd-3e3e236acb3803d336d82ea36e6a88e50bf30f5c.tar.bz2
uhd-3e3e236acb3803d336d82ea36e6a88e50bf30f5c.zip
cmake: Add warning when building non-stable branch
Diffstat (limited to 'host/CMakeLists.txt')
-rw-r--r--host/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/host/CMakeLists.txt b/host/CMakeLists.txt
index df5384adc..be196198b 100644
--- a/host/CMakeLists.txt
+++ b/host/CMakeLists.txt
@@ -423,5 +423,19 @@ ELSEIF(UHDHOST_PKG)
SET(PRINT_APPEND " (Debian uhd-host package configuration)")
ENDIF(LIBUHD_PKG)
UHD_PRINT_COMPONENT_SUMMARY()
+IF(UHD_VERSION_DEVEL)
+ MESSAGE(STATUS "******************************************************")
+ IF(UHD_VERSION_PATCH STREQUAL "git")
+ MESSAGE(STATUS "* You are building the UHD development master branch.")
+ MESSAGE(STATUS "* For production code, we recommend our stable,")
+ MESSAGE(STATUS "* releases or using the release branch (maint).")
+ ELSE()
+ MESSAGE(STATUS "* You are building a development branch of UHD.")
+ MESSAGE(STATUS "* These branches are designed to provide early access")
+ MESSAGE(STATUS "* to UHD and USRP features, but should be considered")
+ MESSAGE(STATUS "* unstable and/or experimental!")
+ ENDIF(UHD_VERSION_PATCH STREQUAL "git")
+ MESSAGE(STATUS "******************************************************")
+ENDIF(UHD_VERSION_DEVEL)
MESSAGE(STATUS "Building version: ${UHD_VERSION}${PRINT_APPEND}")
MESSAGE(STATUS "Using install prefix: ${CMAKE_INSTALL_PREFIX}")