aboutsummaryrefslogtreecommitdiffstats
path: root/host/CMakeLists.txt
diff options
context:
space:
mode:
authorJosh Blum <josh@joshknows.com>2010-03-23 20:44:50 -0700
committerJosh Blum <josh@joshknows.com>2010-03-23 20:44:50 -0700
commit24bd27b90d06820d858c008cff915319873321c5 (patch)
treecadca487d3f804ad73bc0476b3f44a62eb33d306 /host/CMakeLists.txt
parent1aef83037f6a9988b06a547710afbbe5ce815459 (diff)
downloaduhd-24bd27b90d06820d858c008cff915319873321c5.tar.gz
uhd-24bd27b90d06820d858c008cff915319873321c5.tar.bz2
uhd-24bd27b90d06820d858c008cff915319873321c5.zip
Reorganized apps dir into utils and examples dir.
The files get installed into the pkg data directory.
Diffstat (limited to 'host/CMakeLists.txt')
-rw-r--r--host/CMakeLists.txt10
1 files changed, 6 insertions, 4 deletions
diff --git a/host/CMakeLists.txt b/host/CMakeLists.txt
index 2f5d03f7d..148ba2d00 100644
--- a/host/CMakeLists.txt
+++ b/host/CMakeLists.txt
@@ -34,8 +34,9 @@ INCLUDE(CPack) #include after setting vars
########################################################################
SET(RUNTIME_DIR bin)
SET(LIBRARY_DIR lib)
-SET(RESOURCE_DIR share)
-SET(HEADER_DIR include)
+SET(INCLUDE_DIR include)
+SET(PKG_DATA_DIR share/uhd)
+MESSAGE(STATUS "Using install prefix: ${CMAKE_INSTALL_PREFIX}")
########################################################################
# Local Include Dir
@@ -74,7 +75,7 @@ ENDIF(WIN32)
# Setup Boost
########################################################################
SET(Boost_ADDITIONAL_VERSIONS "1.42.0" "1.42")
-FIND_PACKAGE(Boost 1.36 REQUIRED
+FIND_PACKAGE(Boost 1.36 REQUIRED COMPONENTS
date_time
filesystem
program_options
@@ -126,7 +127,8 @@ INSTALL(
########################################################################
# Add the subdirectories
########################################################################
-ADD_SUBDIRECTORY(apps)
+ADD_SUBDIRECTORY(examples)
ADD_SUBDIRECTORY(include)
ADD_SUBDIRECTORY(lib)
ADD_SUBDIRECTORY(test)
+ADD_SUBDIRECTORY(utils)