aboutsummaryrefslogtreecommitdiffstats
path: root/host/CMakeLists.txt
diff options
context:
space:
mode:
authorJosh Blum <josh@joshknows.com>2012-01-13 11:27:42 -0800
committerJosh Blum <josh@joshknows.com>2012-01-13 11:27:42 -0800
commit1424488061000ddc471c976c2406ff274d14ae99 (patch)
tree0d4b30268effff8ab30295e0d78beb15490c8c4d /host/CMakeLists.txt
parent02eaed1b08be2160232d5fc12e3d5926f6c03a9f (diff)
downloaduhd-1424488061000ddc471c976c2406ff274d14ae99.tar.gz
uhd-1424488061000ddc471c976c2406ff274d14ae99.tar.bz2
uhd-1424488061000ddc471c976c2406ff274d14ae99.zip
uhd: patch to support PKG_LIB_DIR per debian fs standards
uhd binaries will continue to install into share/uhd, however, one can specify -DPKG_LIB_DIR=lib/uhd for example to move where the binaries are installed
Diffstat (limited to 'host/CMakeLists.txt')
-rw-r--r--host/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/host/CMakeLists.txt b/host/CMakeLists.txt
index 40d034de5..05dd73d01 100644
--- a/host/CMakeLists.txt
+++ b/host/CMakeLists.txt
@@ -42,6 +42,9 @@ SET(RUNTIME_DIR bin)
SET(LIBRARY_DIR lib${LIB_SUFFIX})
SET(INCLUDE_DIR include)
SET(PKG_DATA_DIR share/uhd)
+IF(NOT DEFINED PKG_LIB_DIR)
+ SET(PKG_LIB_DIR ${PKG_DATA_DIR})
+ENDIF()
SET(PKG_DOC_DIR share/doc/uhd)
########################################################################