aboutsummaryrefslogtreecommitdiffstats
path: root/firmware/zpu/usrp2p/CMakeLists.txt
diff options
context:
space:
mode:
authorJosh Blum <josh@joshknows.com>2011-01-10 13:36:36 -0800
committerJosh Blum <josh@joshknows.com>2011-01-10 13:36:36 -0800
commitd52cf5e16d6d3769071da4ae23408ddac300beeb (patch)
tree2c467535099e1e5f5e9861eb062abb00d37dce8b /firmware/zpu/usrp2p/CMakeLists.txt
parent901bfcbd2bbfe537dead32d08cdf06b7319d9ec6 (diff)
downloaduhd-d52cf5e16d6d3769071da4ae23408ddac300beeb.tar.gz
uhd-d52cf5e16d6d3769071da4ae23408ddac300beeb.tar.bz2
uhd-d52cf5e16d6d3769071da4ae23408ddac300beeb.zip
usrp2: replaced pad argument to gen bins macro with a setting variable, simplifies code
Diffstat (limited to 'firmware/zpu/usrp2p/CMakeLists.txt')
-rw-r--r--firmware/zpu/usrp2p/CMakeLists.txt8
1 files changed, 5 insertions, 3 deletions
diff --git a/firmware/zpu/usrp2p/CMakeLists.txt b/firmware/zpu/usrp2p/CMakeLists.txt
index f93924bc0..93ccf82c3 100644
--- a/firmware/zpu/usrp2p/CMakeLists.txt
+++ b/firmware/zpu/usrp2p/CMakeLists.txt
@@ -36,14 +36,16 @@ ADD_LIBRARY(libusrp2pfw STATIC
ADD_SUBDIRECTORY(bootloader)
########################################################################
+SET(GEN_OUTPUTS_BIN_SIZE 0x3fff)
+
ADD_EXECUTABLE(usrp2p_txrx_uhd.elf ${CMAKE_SOURCE_DIR}/apps/txrx_uhd.c)
TARGET_LINK_LIBRARIES(usrp2p_txrx_uhd.elf libusrp2pfw)
-GEN_OUTPUTS(usrp2p_txrx_uhd.elf 0x3fff)
+GEN_OUTPUTS(usrp2p_txrx_uhd.elf)
ADD_EXECUTABLE(usrp2p_blinkenlights.elf ${CMAKE_SOURCE_DIR}/apps/blinkenlights.c)
TARGET_LINK_LIBRARIES(usrp2p_blinkenlights.elf libusrp2pfw)
-GEN_OUTPUTS(usrp2p_blinkenlights.elf 0x3fff)
+GEN_OUTPUTS(usrp2p_blinkenlights.elf)
ADD_EXECUTABLE(usrp2p_uart_flash_loader.elf ${CMAKE_SOURCE_DIR}/apps/uart_flash_loader.c)
TARGET_LINK_LIBRARIES(usrp2p_uart_flash_loader.elf libusrp2pfw)
-GEN_OUTPUTS(usrp2p_uart_flash_loader.elf 0x3fff)
+GEN_OUTPUTS(usrp2p_uart_flash_loader.elf)