aboutsummaryrefslogtreecommitdiffstats
path: root/firmware/zpu/usrp2p/CMakeLists.txt
diff options
context:
space:
mode:
authorJosh Blum <josh@joshknows.com>2011-01-10 12:23:08 -0800
committerJosh Blum <josh@joshknows.com>2011-01-10 12:23:08 -0800
commit2106c6cf594866061f56b09d1396bb80df51802e (patch)
tree65c94c63d5737d88653d87e7285627650318b55a /firmware/zpu/usrp2p/CMakeLists.txt
parent916223ef3544452bee57b08f9593aa9da66212a5 (diff)
downloaduhd-2106c6cf594866061f56b09d1396bb80df51802e.tar.gz
uhd-2106c6cf594866061f56b09d1396bb80df51802e.tar.bz2
uhd-2106c6cf594866061f56b09d1396bb80df51802e.zip
usrp2: firmware pad bins to zero to deal with optimizing out the static vars that init to zero
removed the spi flash init in favor of an initialization constant at zero tweaked the cmakelists flags list added pad option to the gen binaries macro
Diffstat (limited to 'firmware/zpu/usrp2p/CMakeLists.txt')
-rw-r--r--firmware/zpu/usrp2p/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/firmware/zpu/usrp2p/CMakeLists.txt b/firmware/zpu/usrp2p/CMakeLists.txt
index 74d9e233d..f93924bc0 100644
--- a/firmware/zpu/usrp2p/CMakeLists.txt
+++ b/firmware/zpu/usrp2p/CMakeLists.txt
@@ -38,12 +38,12 @@ ADD_SUBDIRECTORY(bootloader)
########################################################################
ADD_EXECUTABLE(usrp2p_txrx_uhd.elf ${CMAKE_SOURCE_DIR}/apps/txrx_uhd.c)
TARGET_LINK_LIBRARIES(usrp2p_txrx_uhd.elf libusrp2pfw)
-GEN_OUTPUTS(usrp2p_txrx_uhd.elf)
+GEN_OUTPUTS(usrp2p_txrx_uhd.elf 0x3fff)
ADD_EXECUTABLE(usrp2p_blinkenlights.elf ${CMAKE_SOURCE_DIR}/apps/blinkenlights.c)
TARGET_LINK_LIBRARIES(usrp2p_blinkenlights.elf libusrp2pfw)
-GEN_OUTPUTS(usrp2p_blinkenlights.elf)
+GEN_OUTPUTS(usrp2p_blinkenlights.elf 0x3fff)
ADD_EXECUTABLE(usrp2p_uart_flash_loader.elf ${CMAKE_SOURCE_DIR}/apps/uart_flash_loader.c)
TARGET_LINK_LIBRARIES(usrp2p_uart_flash_loader.elf libusrp2pfw)
-GEN_OUTPUTS(usrp2p_uart_flash_loader.elf)
+GEN_OUTPUTS(usrp2p_uart_flash_loader.elf 0x3fff)