aboutsummaryrefslogtreecommitdiffstats
path: root/firmware/octoclock/octoclock_r4/CMakeLists.txt
diff options
context:
space:
mode:
authorNicholas Corgan <nick.corgan@ettus.com>2014-07-17 11:50:50 -0700
committerNicholas Corgan <nick.corgan@ettus.com>2014-07-23 07:37:32 -0700
commita6e18604befdb6a954542f7722c8d55424065621 (patch)
tree22168e6f4c41c931e38ccd07ff8881b56c8cd88a /firmware/octoclock/octoclock_r4/CMakeLists.txt
parent7423d1691fff3af08f8e42e3e09d8c8d9ec99fe8 (diff)
downloaduhd-a6e18604befdb6a954542f7722c8d55424065621.tar.gz
uhd-a6e18604befdb6a954542f7722c8d55424065621.tar.bz2
uhd-a6e18604befdb6a954542f7722c8d55424065621.zip
OctoClock firmware upgrade, added host driver
* OctoClock can communicate with UHD over Ethernet * Can read NMEA strings from GPSDO and send to host * Added multi_usrp_clock class for clock devices * uhd::device can now filter to return only USRP devices or clock devices * New OctoClock bootloader can accept firmware download over Ethernet * Added octoclock_burn_eeprom,octoclock_firmware_burner utilities * Added test_clock_synch example to show clock API
Diffstat (limited to 'firmware/octoclock/octoclock_r4/CMakeLists.txt')
-rw-r--r--firmware/octoclock/octoclock_r4/CMakeLists.txt47
1 files changed, 47 insertions, 0 deletions
diff --git a/firmware/octoclock/octoclock_r4/CMakeLists.txt b/firmware/octoclock/octoclock_r4/CMakeLists.txt
new file mode 100644
index 000000000..a030d3249
--- /dev/null
+++ b/firmware/octoclock/octoclock_r4/CMakeLists.txt
@@ -0,0 +1,47 @@
+#
+# Copyright 2014 Ettus Research LLC
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+
+add_executable(octoclock_r4_fw.elf octoclock_r4_main.c)
+target_link_libraries(octoclock_r4_fw.elf octoclock)
+
+add_custom_command(
+ OUTPUT ${CMAKE_BINARY_DIR}/octoclock_r4_fw.bin
+ DEPENDS octoclock_r4_fw.elf
+ COMMENT "Generating octoclock_r4_fw.bin"
+ COMMAND ${AVR_OBJCOPY} -O binary ${CMAKE_CURRENT_BINARY_DIR}/octoclock_r4_fw.elf ${CMAKE_BINARY_DIR}/octoclock_r4_fw.bin
+)
+add_custom_target(
+ octoclock_r4_fw_bin ALL
+ DEPENDS ${CMAKE_BINARY_DIR}/octoclock_r4_fw.bin
+)
+add_custom_command(
+ OUTPUT ${CMAKE_BINARY_DIR}/octoclock_r4_fw.hex
+ DEPENDS octoclock_r4_fw.elf
+ COMMENT "Generating octoclock_r4_fw.hex"
+ COMMAND ${AVR_OBJCOPY} -O ihex ${CMAKE_CURRENT_BINARY_DIR}/octoclock_r4_fw.elf ${CMAKE_BINARY_DIR}/octoclock_r4_fw.hex
+)
+add_custom_target(
+ octoclock_r4_fw_hex ALL
+ DEPENDS ${CMAKE_BINARY_DIR}/octoclock_r4_fw.hex
+)
+add_custom_target(
+ upload_r4
+ ${AVRDUDE} -p atmega128 -c ${PROGRAMMER} -P usb -U efuse:w:0xFF:m -U hfuse:w:0x81:m -U lfuse:w:0xFF:m -U flash:w:octoclock_r4_fw.hex:i
+ WORKING_DIRECTORY ${CMAKE_BINARY_DIR}
+ DEPENDS octoclock_r4_fw_hex
+ COMMENT "Uploading OctoClock firmware to device with ${PROGRAMMER}"
+)