aboutsummaryrefslogtreecommitdiffstats
path: root/firmware/fx2/CMakeLists.txt
diff options
context:
space:
mode:
authorJosh Blum <josh@joshknows.com>2010-11-05 21:22:54 -0700
committerJosh Blum <josh@joshknows.com>2010-11-05 21:22:54 -0700
commit374f6ff05e66d10830a7567d2d793de2bf77c06b (patch)
treeca170bd9473de690ffff45b2041cf10f83fb0228 /firmware/fx2/CMakeLists.txt
parent92b5034cb5a6e17fe7ebc437f7ef26147d69eba3 (diff)
parentc2cc364f9fde9633e2d7c04fa5b07275e17ba093 (diff)
downloaduhd-374f6ff05e66d10830a7567d2d793de2bf77c06b.tar.gz
uhd-374f6ff05e66d10830a7567d2d793de2bf77c06b.tar.bz2
uhd-374f6ff05e66d10830a7567d2d793de2bf77c06b.zip
Merge branch 'master' into flow_ctrl
Conflicts: host/lib/usrp/usrp2/mboard_impl.cpp host/lib/usrp/usrp2/usrp2_impl.hpp
Diffstat (limited to 'firmware/fx2/CMakeLists.txt')
-rw-r--r--firmware/fx2/CMakeLists.txt47
1 files changed, 47 insertions, 0 deletions
diff --git a/firmware/fx2/CMakeLists.txt b/firmware/fx2/CMakeLists.txt
new file mode 100644
index 000000000..80f16363f
--- /dev/null
+++ b/firmware/fx2/CMakeLists.txt
@@ -0,0 +1,47 @@
+#
+# Copyright 2010 Ettus Research LLC
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+
+CMAKE_MINIMUM_REQUIRED(VERSION 2.6)
+set(CMAKE_TOOLCHAIN_FILE ${CMAKE_SOURCE_DIR}/config/Toolchain-sdcc.cmake)
+PROJECT(USRP1 C)
+set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} "${CMAKE_SOURCE_DIR}/config/")
+INCLUDE(FindPythonInterp)
+
+########################################################################
+# Set toolchain to use SDCC
+########################################################################
+# we're doing mixed ASM and C
+ENABLE_LANGUAGE(ASM_SDCC)
+
+########################################################################
+# C flags and linking flags
+########################################################################
+ADD_DEFINITIONS(-DHAVE_USRP2)
+set(CMAKE_C_LINK_FLAGS "--code-loc 0x0000 --code-size 0x1800 --xram-loc 0x1800 --xram-size 0x0800 -Wl '-b USBDESCSEG = 0xE000'")
+set(CMAKE_C_FLAGS "--no-xinit-opt")
+
+########################################################################
+# Setup precompile tools
+########################################################################
+set(REG_GENERATOR ${CMAKE_SOURCE_DIR}/utils/generate_regs.py)
+set(EDIT_GPIF_USRP1 ${CMAKE_SOURCE_DIR}/utils/edit-gpif.py)
+set(BUILD_EEPROM ${CMAKE_SOURCE_DIR}/utils/build_eeprom.py)
+
+########################################################################
+# Add the subdirectories
+########################################################################
+ADD_SUBDIRECTORY(usrp1)