aboutsummaryrefslogtreecommitdiffstats
path: root/sw/eval-clock-cw-tx/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'sw/eval-clock-cw-tx/Cargo.toml')
-rw-r--r--sw/eval-clock-cw-tx/Cargo.toml4
1 files changed, 3 insertions, 1 deletions
diff --git a/sw/eval-clock-cw-tx/Cargo.toml b/sw/eval-clock-cw-tx/Cargo.toml
index b56ac96..ebf3e20 100644
--- a/sw/eval-clock-cw-tx/Cargo.toml
+++ b/sw/eval-clock-cw-tx/Cargo.toml
@@ -15,11 +15,13 @@ cortex-m-semihosting = "0.3"
panic-semihosting = "0.5"
nb = "1.0"
#stm32h7 = { version = "0.9", features = ["stm32h743", "rt"] }
-stm32f1xx-hal = { version = "0.7", features = ["rt", "stm32f103", "medium"] }
+stm32f1xx-hal = { version = "0.7", features = ["rt", "stm32f103", "medium", "stm32-usbd"] }
embedded-hal = { version = "0.2", features = [] }
shared-bus = { version = "0.2", features = ["cortex-m"] }
hd44780-driver = { path = "../deps/hd44780-driver"}
si5351 = { path = "../deps/si5351" }
+usb-device = { version = "0.2" }
+usbd-serial = { version = "0.1" }
[profile.dev]
codegen-units = 1