aboutsummaryrefslogtreecommitdiffstats
path: root/sw/eval-clock-cw-tx/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'sw/eval-clock-cw-tx/Cargo.toml')
-rw-r--r--sw/eval-clock-cw-tx/Cargo.toml33
1 files changed, 33 insertions, 0 deletions
diff --git a/sw/eval-clock-cw-tx/Cargo.toml b/sw/eval-clock-cw-tx/Cargo.toml
new file mode 100644
index 0000000..b56ac96
--- /dev/null
+++ b/sw/eval-clock-cw-tx/Cargo.toml
@@ -0,0 +1,33 @@
+[package]
+name = "eval_clock_cw_tx"
+version = "0.1.0"
+authors = ["Matthias P. Braendli <matthias.braendli@mpb.li>"]
+edition = "2018"
+license = "MIT"
+
+[dependencies]
+arrayvec = { version = "0.5", default-features = false, features = [] }
+# alloc-cortex-m = "0.3" # requires nightly
+cortex-m = "0.6"
+cortex-m-rt = "0.6"
+# consider cortex-m-rtfm
+cortex-m-semihosting = "0.3"
+panic-semihosting = "0.5"
+nb = "1.0"
+#stm32h7 = { version = "0.9", features = ["stm32h743", "rt"] }
+stm32f1xx-hal = { version = "0.7", features = ["rt", "stm32f103", "medium"] }
+embedded-hal = { version = "0.2", features = [] }
+shared-bus = { version = "0.2", features = ["cortex-m"] }
+hd44780-driver = { path = "../deps/hd44780-driver"}
+si5351 = { path = "../deps/si5351" }
+
+[profile.dev]
+codegen-units = 1
+incremental = false
+opt-level = 'z'
+
+[profile.release]
+codegen-units = 1
+debug = true
+lto = true
+opt-level = 'z'