aboutsummaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2018-06-03 16:18:18 +0200
committerHarald Welte <laforge@gnumonks.org>2018-06-03 16:25:32 +0200
commit8e17744c1a375d72a52cf9f9e209667d9ea61ebc (patch)
treee8e978bf925eeee0d6d1cbe3ffb01e4d10f7845c /debian/rules
parentb9fff5b405751881f36a75b0e05b9355df327e2f (diff)
downloadosmo-fl2k-8e17744c1a375d72a52cf9f9e209667d9ea61ebc.tar.gz
osmo-fl2k-8e17744c1a375d72a52cf9f9e209667d9ea61ebc.tar.bz2
osmo-fl2k-8e17744c1a375d72a52cf9f9e209667d9ea61ebc.zip
Add Debian packaging information
This allows (among others) to build rtl-sdr nightly packages for a variety of distributions as part of the network:osmocom:nightly builds.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules11
1 files changed, 11 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..74833df
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,11 @@
+#!/usr/bin/make -f
+
+#export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+
+%:
+ dh $@ --with autoreconf
+
+# Print test results in case of a failure
+override_dh_auto_test:
+ dh_auto_test || (find . -name testsuite.log -exec cat {} \; ; false)