aboutsummaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorMatthias P. Braendli <matthias.braendli@mpb.li>2019-03-23 00:03:29 +0100
committerMatthias P. Braendli <matthias.braendli@mpb.li>2019-03-23 00:03:29 +0100
commit2cf0eaffddab2457fc81d672599c0f58eb6950f9 (patch)
treef1964cdc4d9a4f7ff8ffa15b2a359cdad55a58d8 /debian/rules
parenteb11e68412b49b0945ab6bb332ac9486f1ebeb9e (diff)
parentdf33203db5007218384e6724748be52a1d4fdb25 (diff)
downloadosmo-fl2k-2cf0eaffddab2457fc81d672599c0f58eb6950f9.tar.gz
osmo-fl2k-2cf0eaffddab2457fc81d672599c0f58eb6950f9.tar.bz2
osmo-fl2k-2cf0eaffddab2457fc81d672599c0f58eb6950f9.zip
Merge remote-tracking branch 'upstream/master' into interleaved_rg
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules11
1 files changed, 11 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..74833df
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,11 @@
+#!/usr/bin/make -f
+
+#export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+
+%:
+ dh $@ --with autoreconf
+
+# Print test results in case of a failure
+override_dh_auto_test:
+ dh_auto_test || (find . -name testsuite.log -exec cat {} \; ; false)