aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFelix Erckenbrecht <eligs@eligs.de>2022-03-25 08:42:52 +0100
committerFelix Erckenbrecht <eligs@eligs.de>2022-03-25 08:42:52 +0100
commit3f05271da3e6f4a4561e440c4c8a0cdce3636f73 (patch)
tree16fb66cd7a27cda449e409cba98afd878281e74f /CMakeLists.txt
parentff19a05e83ec67ec736eb5033fb5cdc900ffe3f0 (diff)
parent197f421c98f929d4266a09bc9d667b7869e09c27 (diff)
downloadosmo-fl2k-3f05271da3e6f4a4561e440c4c8a0cdce3636f73.tar.gz
osmo-fl2k-3f05271da3e6f4a4561e440c4c8a0cdce3636f73.tar.bz2
osmo-fl2k-3f05271da3e6f4a4561e440c4c8a0cdce3636f73.zip
Merge branch 'master' into ampliphase: Get lib updates and other fixes
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5fb110f..84bc55d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -24,6 +24,11 @@ project(libosmo-fl2k C)
include(GNUInstallDirs)
+# CMP0075 Include file check macros honor CMAKE_REQUIRED_LIBRARIES
+if(POLICY CMP0075)
+ cmake_policy(SET CMP0075 NEW)
+endif()
+
#select the release build type by default to get optimization flags
if(NOT CMAKE_BUILD_TYPE)
set(CMAKE_BUILD_TYPE "Release")