aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 190837c..5e1ed2d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -49,6 +49,7 @@ add_definitions(-Wall)
########################################################################
find_package(PkgConfig)
+pkg_check_modules(UHD uhd)
# Threads
find_package(Threads REQUIRED)
@@ -59,9 +60,10 @@ find_package(Threads REQUIRED)
list(APPEND odrdpd_sources
main.cpp
+ OutputUHD.cpp
)
-#list(APPEND common_link_list stuff to link against)
+list(APPEND common_link_list ${UHD_LIBRARIES} ${CMAKE_THREAD_LIBS_INIT})
set_source_files_properties(
${odrdpd_sources}