aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 59067e1..2304b01 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -52,6 +52,8 @@ find_package(PkgConfig)
pkg_check_modules(UHD uhd)
pkg_check_modules(ZMQ libzmq)
pkg_check_modules(FFTW3F fftw3f)
+pkg_check_modules(SDL sdl)
+pkg_check_modules(GLU glu)
# Threads
find_package(Threads REQUIRED)
@@ -64,10 +66,13 @@ list(APPEND odrdpd_sources
main.cpp
OutputUHD.cpp
AlignSample.cpp
+ pointcloud.cpp
)
list(APPEND common_link_list
${UHD_LIBRARIES}
+ ${SDL_LIBRARIES}
+ ${GLU_LIBRARIES}
${ZMQ_LIBRARIES}
${FFTW3F_LIBRARIES}
${CMAKE_THREAD_LIBS_INIT})