aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorMatthias P. Braendli <matthias.braendli@mpb.li>2024-09-19 22:09:20 +0200
committerMatthias P. Braendli <matthias.braendli@mpb.li>2024-09-19 22:09:20 +0200
commiteec01c9b72feff9533477014881b982124ca7b6d (patch)
tree084586316e04f01f48b479de0cb41113639ac8d5 /Cargo.toml
downloadodr-dabmux-gui-eec01c9b72feff9533477014881b982124ca7b6d.tar.gz
odr-dabmux-gui-eec01c9b72feff9533477014881b982124ca7b6d.tar.bz2
odr-dabmux-gui-eec01c9b72feff9533477014881b982124ca7b6d.zip
Create project
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml27
1 files changed, 27 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..2c3809c
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,27 @@
+[package]
+name = "odr-dabmux-gui"
+version = "0.0.1"
+edition = "2021"
+authors = ["Matthias P. Braendli <matthias.braendli@mpb.li>"]
+license = "GPLv3"
+
+[dependencies]
+anyhow = "1.0"
+askama = { version = "0.12", features = ["with-axum"] }
+askama_axum = "0.4"
+axum = { version = "0.7", features = ["ws"] }
+#axum-extra = "0.7"
+chrono = { version = "0.4", features = ["serde"] }
+simple_logger = "5.0"
+log = "0.4"
+serde = { version = "1.0", features = ["derive"] }
+serde_json = "1.0"
+toml = "0.8"
+# sqlx = { version = "0.7", features = [ "runtime-tokio-rustls", "sqlite"]}
+tokio = { version = "1", features = ["full"] }
+tokio-tungstenite = "0.21"
+tower-http = { version = "0.5.0", features = ["fs"] }
+
+futures-core = "0.3"
+futures= "0.3"
+tun = { version = "0.6", features = ["async"] }