aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index a3fdb00..292a6ac 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -40,10 +40,14 @@ libfdk_aac_la_LDFLAGS = -version-info @FDK_AAC_VERSION@ -no-undefined \
if EXAMPLE
bin_PROGRAMS = aac-enc$(EXEEXT)
+noinst_PROGRAMS = test-encode-decode$(EXEEXT)
aac_enc_LDADD = libfdk-aac.la
aac_enc_SOURCES = aac-enc.c wavreader.c
+test_encode_decode_LDADD = libfdk-aac.la
+test_encode_decode_SOURCES = test-encode-decode.c wavreader.c sha1.c
+
noinst_HEADERS = wavreader.h
endif
@@ -279,7 +283,6 @@ EXTRA_DIST = \
$(top_srcdir)/libSBRenc/src/*.h \
$(top_srcdir)/libSBRenc/include/*.h \
$(top_srcdir)/libSBRdec/src/*.h \
- $(top_srcdir)/libSBRdec/src/arm/*.cpp \
$(top_srcdir)/libSBRdec/include/*.h \
$(top_srcdir)/libSYS/include/*.h \
$(top_srcdir)/libPCMutils/include/*.h \
@@ -297,5 +300,7 @@ EXTRA_DIST = \
$(top_srcdir)/libFDK/src/mips/*.cpp \
$(top_srcdir)/METADATA \
$(top_srcdir)/PREUPLOAD.cfg \
+ $(top_srcdir)/sha1.h \
+ $(top_srcdir)/test/* \
$(top_srcdir)/win32/*.h