aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMatthias P. Braendli <matthias.braendli@mpb.li>2017-07-21 14:31:41 +0200
committerMatthias P. Braendli <matthias.braendli@mpb.li>2017-07-21 14:31:41 +0200
commit89639e36b29a622c641c3de3a4737a4c848dc365 (patch)
tree2eadccdf7e7eb39cdc8c0087a7bf933150a412d5 /Makefile.am
parentd450e652c5f963a2ef3a9392f55ca07c7e06dc6c (diff)
parentaf5863a78efdfccd003dd6bea68c4a2cd2ad9f37 (diff)
downloadfdk-aac-89639e36b29a622c641c3de3a4737a4c848dc365.tar.gz
fdk-aac-89639e36b29a622c641c3de3a4737a4c848dc365.tar.bz2
fdk-aac-89639e36b29a622c641c3de3a4737a4c848dc365.zip
Merge 'mstorjo/master' into dabplus
This adds support for AArch64 and other improvements listed in the ChangeLog
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 5cd4b3a..11fbef1 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -12,7 +12,7 @@ AM_CPPFLAGS = \
-I$(top_srcdir)/libFDK/include \
-I$(top_srcdir)/libPCMutils/include
-AM_CXXFLAGS = -fno-exceptions -fno-rtti -std=c++98
+AM_CXXFLAGS = -fno-exceptions -fno-rtti
libfdk_aac_la_LINK = $(LINK) $(libfdk_aac_la_LDFLAGS)
# Mention a dummy pure C file to trigger generation of the $(LINK) variable
nodist_EXTRA_libfdk_aac_la_SOURCES = dummy.c
@@ -187,9 +187,11 @@ libfdk_aac_la_SOURCES = \
EXTRA_DIST = \
$(top_srcdir)/autogen.sh \
+ $(top_srcdir)/MODULE_LICENSE_FRAUNHOFER \
$(top_srcdir)/NOTICE \
$(top_srcdir)/Android.mk \
$(top_srcdir)/fdk-aac.sym \
+ $(top_srcdir)/Makefile.vc \
$(top_srcdir)/documentation/*.pdf \
$(top_srcdir)/libAACdec/src/*.h \
$(top_srcdir)/libAACdec/src/arm/*.cpp \
@@ -210,10 +212,12 @@ EXTRA_DIST = \
$(top_srcdir)/libMpegTPDec/src/*.h \
$(top_srcdir)/libMpegTPDec/src/version \
$(top_srcdir)/libFDK/include/*.h \
+ $(top_srcdir)/libFDK/include/aarch64/*.h \
$(top_srcdir)/libFDK/include/arm/*.h \
$(top_srcdir)/libFDK/include/mips/*.h \
$(top_srcdir)/libFDK/include/ppc/*.h \
$(top_srcdir)/libFDK/include/x86/*.h \
$(top_srcdir)/libFDK/src/arm/*.cpp \
- $(top_srcdir)/libFDK/src/mips/*.cpp
+ $(top_srcdir)/libFDK/src/mips/*.cpp \
+ $(top_srcdir)/win32/*.h