aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMartin Storsjo <martin@martin.st>2017-06-27 14:47:01 +0300
committerMartin Storsjo <martin@martin.st>2023-10-06 14:49:49 +0300
commit1fbe8eb3bd0907aadf5a97283866ca797370bb18 (patch)
tree77e3291aa738b6e958af715ef72e85cba61feb81 /Makefile.am
parent226848a2a10c2b56a4385417a8b2e3fb048fd952 (diff)
downloadfdk-aac-1fbe8eb3bd0907aadf5a97283866ca797370bb18.tar.gz
fdk-aac-1fbe8eb3bd0907aadf5a97283866ca797370bb18.tar.bz2
fdk-aac-1fbe8eb3bd0907aadf5a97283866ca797370bb18.zip
Add a tool for testing decoding+encoding in a number of configurations
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 8f55cf0..c71af1d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -40,10 +40,14 @@ libfdk_aac_la_LDFLAGS = -version-info @FDK_AAC_VERSION@ -no-undefined \
if EXAMPLE
bin_PROGRAMS = aac-enc$(EXEEXT)
+noinst_PROGRAMS = test-encode-decode$(EXEEXT)
aac_enc_LDADD = libfdk-aac.la
aac_enc_SOURCES = aac-enc.c wavreader.c
+test_encode_decode_LDADD = libfdk-aac.la
+test_encode_decode_SOURCES = test-encode-decode.c wavreader.c sha1.c
+
noinst_HEADERS = wavreader.h
endif