aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMartin Storsjo <martin@martin.st>2021-04-28 15:31:57 +0300
committerMartin Storsjo <martin@martin.st>2021-04-28 15:33:55 +0300
commit9e8181c03bfe64585231681fa79f2ca7a0b81989 (patch)
tree17c26fd65ab87fe94fea1e8004492ac805c91981 /CMakeLists.txt
parentb0789a343871e99db4bca6cea937772117dbed5b (diff)
downloadfdk-aac-9e8181c03bfe64585231681fa79f2ca7a0b81989.tar.gz
fdk-aac-9e8181c03bfe64585231681fa79f2ca7a0b81989.tar.bz2
fdk-aac-9e8181c03bfe64585231681fa79f2ca7a0b81989.zip
Specify the macOS compatibility version to make it a drop-in replacement for the libtool built
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 314ba84..f768025 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -488,7 +488,9 @@ target_link_libraries(fdk-aac PRIVATE $<$<BOOL:${HAVE_LIBM}>:m>)
set_target_properties(fdk-aac PROPERTIES
PUBLIC_HEADER "${fdk_aacinclude_HEADERS}"
VERSION 2.0.1
- SOVERSION 2)
+ SOVERSION 2
+ MACHO_COMPATIBILITY_VERSION 3.0.0
+ MACHO_CURRENT_VERSION 3.1.0)
### Some compiler options from Makefile.am
if(MSVC)