aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMatthias P. Braendli <matthias.braendli@mpb.li>2016-02-26 01:34:08 +0100
committerMatthias P. Braendli <matthias.braendli@mpb.li>2016-02-26 01:34:08 +0100
commit84254c10d2898fbe7f45934bcaad94a217cc22ab (patch)
tree4a2d468800a3318e38c95983d5c390c8e1f4b9cc /Makefile.am
parent7af7b3dd5f1a4bdef4748079dfee86c81d00bee9 (diff)
downloadfdk-aac-dabplus-84254c10d2898fbe7f45934bcaad94a217cc22ab.tar.gz
fdk-aac-dabplus-84254c10d2898fbe7f45934bcaad94a217cc22ab.tar.bz2
fdk-aac-dabplus-84254c10d2898fbe7f45934bcaad94a217cc22ab.zip
Make ALSA input conditional
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 9 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 31289bc..388adbb 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -88,11 +88,17 @@ else
dabplus_enc_LDADD_JACK =
endif
+if HAVE_ALSA
+dabplus_enc_LDADD_ALSA = -lasound
+else
+dabplus_enc_LDADD_ALSA =
+endif
dabplus_enc_LDFLAGS = -no-install
dabplus_enc_LDADD = libfdk-dabplus.la libtoolame-dab.la \
- -lfec -lzmq -lasound \
+ -lfec -lzmq \
-lrt $(dabplus_enc_LDADD_JACK) \
+ $(dabplus_enc_LDADD_ALSA) \
$(LIBVLC_LIBS)
dabplus_enc_CPPFLAGS = $(AM_CPPFLAGS) $(GITVERSION_FLAGS) -ggdb -O2
dabplus_enc_SOURCES = src/dabplus-enc.cpp \
@@ -115,7 +121,8 @@ dabplus_enc_SOURCES = src/dabplus-enc.cpp \
src/utf8.h \
src/utf8/checked.h \
src/utf8/unchecked.h \
- src/utf8/core.h
+ src/utf8/core.h \
+ src/common.h
mot_encoder_CXXFLAGS = $(GITVERSION_FLAGS) @MAGICKWAND_CFLAGS@ -Icontrib
mot_encoder_LDADD = @MAGICKWAND_LDADD@