aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthias P. Braendli <matthias.braendli@mpb.li>2017-06-23 16:21:39 +0200
committerMatthias P. Braendli <matthias.braendli@mpb.li>2017-06-23 16:21:39 +0200
commitfcc6b39a136349870357ace9e431ff0e437f46d4 (patch)
treebdf8b32d57fde1e04f91965441385148774af2a9 /configure.ac
parent16cf18056b8b79f9b3e86b09bc91f55f714a9ff1 (diff)
downloaddabmod-fcc6b39a136349870357ace9e431ff0e437f46d4.tar.gz
dabmod-fcc6b39a136349870357ace9e431ff0e437f46d4.tar.bz2
dabmod-fcc6b39a136349870357ace9e431ff0e437f46d4.zip
Add configure option to disable march=native
Packagers must be able to override these options themselves
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac33
1 files changed, 19 insertions, 14 deletions
diff --git a/configure.ac b/configure.ac
index d39e318..4d94592 100644
--- a/configure.ac
+++ b/configure.ac
@@ -70,6 +70,10 @@ AC_ARG_ENABLE([zeromq],
[AS_HELP_STRING([--disable-zeromq], [Disable ZeroMQ input, output and remote control])],
[], [enable_zeromq=yes])
+AC_ARG_ENABLE([native],
+ [AS_HELP_STRING([--disable-native], [Do not compile with -march=native])],
+ [], [enable_native=yes])
+
# UHD support control
AC_ARG_ENABLE([output_uhd],
[AS_HELP_STRING([--disable-output-uhd], [Disable UHD output])],
@@ -162,20 +166,21 @@ AC_LANG_POP([C++])
# Check for march
-AC_MSG_CHECKING(if we can add -march=native to CFLAGS)
-
-save_CXXFLAGS="$CXXFLAGS"
-CXXFLAGS="$CXXFLAGS -march=native"
-AC_COMPILE_IFELSE( [AC_LANG_PROGRAM([[
-void testfunc(void) {}
-]])],
-[supports_march_native=yes],
-[supports_march_native=no]
-)
-AC_MSG_RESULT($supports_march_native)
-if test x"$supports_march_native" = xno; then
- CXXFLAGS="$save_CXXFLAGS"
-fi
+AS_IF([test "x$enable_native" = "xyes"],
+ [AC_MSG_CHECKING(if we can add -march=native to CFLAGS)
+ save_CXXFLAGS="$CXXFLAGS"
+ CXXFLAGS="$CXXFLAGS -march=native"
+ AC_COMPILE_IFELSE( [AC_LANG_PROGRAM([[
+ void testfunc(void) {}
+ ]])],
+ [supports_march_native=yes],
+ [supports_march_native=no]
+ )
+ AC_MSG_RESULT($supports_march_native)
+ if test x"$supports_march_native" = xno; then
+ CXXFLAGS="$save_CXXFLAGS"
+ fi
+ ])
AC_TYPE_SIGNAL
AC_CHECK_FUNCS([bzero floor ftime gettimeofday memset sqrt strchr strerror strtol])