aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthias P. Braendli <matthias.braendli@mpb.li>2017-12-15 10:07:03 +0100
committerMatthias P. Braendli <matthias.braendli@mpb.li>2017-12-15 10:07:03 +0100
commitf041360ac17bc032c7e5a4553372893e42ba68c6 (patch)
tree99c66c42e7a1fa41e139a334bab6fde39b79c735 /configure.ac
parent477782190324caf69445f59e2a9ce02152c06106 (diff)
downloaddabmod-f041360ac17bc032c7e5a4553372893e42ba68c6.tar.gz
dabmod-f041360ac17bc032c7e5a4553372893e42ba68c6.tar.bz2
dabmod-f041360ac17bc032c7e5a4553372893e42ba68c6.zip
Check for prctl portability
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9bb0ebc..261d444 100644
--- a/configure.ac
+++ b/configure.ac
@@ -173,6 +173,17 @@ AC_COMPILE_IFELSE(
[AC_MSG_RESULT([yes])], [AC_MSG_RESULT([no]) AC_DEFINE([M_PIl], [M_PI], [Replacing define])])
AC_LANG_POP([C++])
+# Linux has prctl to set thread names
+AC_MSG_CHECKING(for prctl and PR_SET_NAME)
+AC_COMPILE_IFELSE([ AC_LANG_PROGRAM([[
+ #include <sys/prctl.h>
+ void set_thread_name() {
+ prctl(PR_SET_NAME,"test",0,0,0);
+ }
+ ]])],
+ [ AC_MSG_RESULT(yes)
+ AC_DEFINE(HAVE_PRCTL, 1, [Define this symbol if you have prctl and PR_SET_NAME]) ],
+ [ AC_MSG_RESULT(no) ])
# Check for march
AS_IF([test "x$enable_native" = "xyes"],