aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorEmil BarczyƄski <barczynsky@domain-yet-to-be.pl>2014-03-21 18:27:45 +0100
committerMatthias P. Braendli <matthias.braendli@mpb.li>2014-03-22 18:26:53 +0100
commit3acf203e565485a0bf8e217163eb7adfc14790bd (patch)
tree07fade3c87b1a6533ac0a79c005338f81dc6b69e /configure.ac
parenta5e82cbf790aaa0d7f352da51398abfb8352afc6 (diff)
downloaddabmod-3acf203e565485a0bf8e217163eb7adfc14790bd.tar.gz
dabmod-3acf203e565485a0bf8e217163eb7adfc14790bd.tar.bz2
dabmod-3acf203e565485a0bf8e217163eb7adfc14790bd.zip
Add configure option to disable UHD
Signed-off-by: Matthias P. Braendli <matthias.braendli@mpb.li>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 8 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 0362102..e01c409 100644
--- a/configure.ac
+++ b/configure.ac
@@ -66,6 +66,9 @@ AC_ARG_ENABLE([fft_simd],
# ZeroMQ message queue input
AC_ARG_ENABLE([input_zeromq],
AS_HELP_STRING([--enable-input-zeromq], [Enable ZeroMQ input]))
+# UHD support control
+AC_ARG_ENABLE([output_uhd],
+ AS_HELP_STRING([--enable-output-uhd], [Enable UHD output]))
AS_IF([test "x$enable_input_zeromq" = "xyes"],
[AC_DEFINE(HAVE_INPUT_ZEROMQ, [1], [Define if ZeroMQ input is enabled]) ,
@@ -86,7 +89,11 @@ AM_CONDITIONAL([HAVE_INPUT_ZEROMQ_TEST], [test "x$enable_input_zeromq" = "xyes"]
AC_SUBST([CFLAGS], ["$OPTIM $DEBUG $EXTRA"])
AC_SUBST([CXXFLAGS], ["$OPTIM $DEBUG $EXTRA"])
-AC_CHECK_LIB([uhd], [main], [], [AC_MSG_ERROR([library uhd is missing])])
+AS_IF([test "x$enable_output_uhd" = "xyes"],
+ [AC_DEFINE(HAVE_OUTPUT_UHD, [1], [Define if UHD output is enabled]) ,
+ AC_CHECK_LIB([uhd], [main], [], [AC_MSG_ERROR([library uhd is missing])])])
+
+AM_CONDITIONAL([HAVE_OUTPUT_UHD_TEST], [test "x$enable_output_uhd" = "xyes"])
AX_BOOST_BASE([1.41.0], [], AC_MSG_ERROR([BOOST 1.41 or later is required]))
AC_CHECK_LIB([boost_system], [main], [], [AC_MSG_ERROR([library boost_system is missing])])