aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthias P. Braendli <matthias.braendli@mpb.li>2018-03-07 12:25:59 +0100
committerMatthias P. Braendli <matthias.braendli@mpb.li>2018-03-07 12:26:10 +0100
commit0265c80544aac93e238bcfb2d61afc547c48a829 (patch)
treee6380ea560a4f0fde1be7fae6acb7db7640948c1 /configure.ac
parent38db981490655c737dac6ef546f65b1e93d1d99a (diff)
downloaddabmod-0265c80544aac93e238bcfb2d61afc547c48a829.tar.gz
dabmod-0265c80544aac93e238bcfb2d61afc547c48a829.tar.bz2
dabmod-0265c80544aac93e238bcfb2d61afc547c48a829.zip
Remove --enable-debug configure flag
With --enable-debug, compiler flags include -g -O2, i.e. with debugging, with optimisations. Without --enable-debug, compiler flags include -g -O2 -DNDEBUG -g -O2 are defaults according to AC_PROG_CXX The macro NDEBUG has a small performance impact (less than 1%), but can put issues to light. It is beneficial to have assertions always enabled. Remove the flag, and let the user override CFLAGS/CXXFLAGS if he wishes to. This is documented in INSTALL.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 1 insertions, 15 deletions
diff --git a/configure.ac b/configure.ac
index adf981b..e5221da 100644
--- a/configure.ac
+++ b/configure.ac
@@ -37,31 +37,21 @@ AC_PROG_INSTALL
AX_CXX_COMPILE_STDCXX_11(noext,mandatory)
EXTRA=""
-AC_ARG_ENABLE([debug],
- [AS_HELP_STRING([--enable-debug], [Enable debugger symbols])],
- [], [enable_debug=no])
AC_ARG_ENABLE([prof],
[AS_HELP_STRING([--enable-prof], [Enable profiling])],
[], [enable_prof=no])
AC_ARG_ENABLE([fast-math],
[AS_HELP_STRING([--enable-fast-math], [Set -ffast-math])],
[], [enable_fast_math=no])
-AC_ARG_WITH([debug-malloc],
- [AS_HELP_STRING([--with-debug-malloc[=no|yes|duma|efence|...]],
- [Add malloc debugger support])],
- [], [with_debug_malloc=no])
AC_ARG_ENABLE([trace],
[AS_HELP_STRING([--enable-trace], [Enable trace output])],
[], [enable_trace=no])
-
AC_ARG_ENABLE([zeromq],
[AS_HELP_STRING([--disable-zeromq], [Disable ZeroMQ input, output and remote control])],
[], [enable_zeromq=yes])
-
AC_ARG_ENABLE([edi],
[AS_HELP_STRING([--enable-edi], [Enable EDI input])],
[], [enable_edi=no])
-
AC_ARG_ENABLE([native],
[AS_HELP_STRING([--disable-native], [Do not compile with -march=native])],
[], [enable_native=yes])
@@ -93,10 +83,6 @@ AS_IF([test "x$enable_zeromq" = "xyes"],
AS_IF([test "x$enable_zeromq" = "xyes"],
[AC_DEFINE(HAVE_ZEROMQ, [1], [Define if ZeroMQ is enabled])])
-AS_IF([test "x$enable_debug" = "xno"],
- [EXTRA="$EXTRA -DNDEBUG"],
- [EXTRA="$EXTRA"])
-
AS_IF([test "x$enable_prof" != "xno"],
[EXTRA="$EXTRA -pg"])
@@ -218,7 +204,7 @@ echo
echo
enabled=""
disabled=""
-for feat in with_debug_malloc supports_march_native enable_fast_math
+for feat in supports_march_native enable_fast_math
do
eval var=\$$feat
AS_IF([test "x$var" != "xno"],