aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMatthias P. Braendli <matthias.braendli@mpb.li>2019-09-05 11:01:56 +0200
committerMatthias P. Braendli <matthias.braendli@mpb.li>2019-09-05 11:01:56 +0200
commit32f9e6e8bfa584f0dfb155c0bb7cdc843614af5c (patch)
tree59cd09a0eaa6469ba7aed1b9b167cfc8643ec68f /Makefile.am
parent0c532ab20b47d661f098cc6089184303dce65d56 (diff)
downloaddabmod-32f9e6e8bfa584f0dfb155c0bb7cdc843614af5c.tar.gz
dabmod-32f9e6e8bfa584f0dfb155c0bb7cdc843614af5c.tar.bz2
dabmod-32f9e6e8bfa584f0dfb155c0bb7cdc843614af5c.zip
Rework EDI input
- Use same main loop for both ETI and EDI inputs - Test SFN functionality with EDI input - Add log.show_process_time setting for process time printout
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am22
1 files changed, 10 insertions, 12 deletions
diff --git a/Makefile.am b/Makefile.am
index 34d2d91..9644c16 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -114,7 +114,16 @@ odr_dabmod_SOURCES = src/DabMod.cpp \
lib/fec/fec.h \
lib/fec/init_rs_char.c \
lib/fec/init_rs.h \
- lib/fec/rs-common.h
+ lib/fec/rs-common.h \
+ lib/edi/buffer_unpack.hpp \
+ lib/edi/common.hpp \
+ lib/edi/common.cpp \
+ lib/edi/eti.hpp \
+ lib/edi/eti.cpp \
+ lib/edi/ETIDecoder.hpp \
+ lib/edi/ETIDecoder.cpp \
+ lib/edi/PFT.hpp \
+ lib/edi/PFT.cpp
if !COMPILE_FOR_EASYDABV3
odr_dabmod_SOURCES += \
@@ -161,14 +170,3 @@ odr_dabmod_SOURCES += \
odr_dabmod_LDADD += $(UHD_LIBS)
endif
-if COMPILE_EDI
-odr_dabmod_SOURCES += lib/edi/buffer_unpack.hpp \
- lib/edi/common.hpp \
- lib/edi/common.cpp \
- lib/edi/eti.hpp \
- lib/edi/eti.cpp \
- lib/edi/ETIDecoder.hpp \
- lib/edi/ETIDecoder.cpp \
- lib/edi/PFT.hpp \
- lib/edi/PFT.cpp
-endif