aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorMatthias P. Braendli <matthias.braendli@mpb.li>2024-01-01 23:05:29 +0100
committerMatthias P. Braendli <matthias.braendli@mpb.li>2024-01-01 23:05:29 +0100
commit96c6f2154007649c32fa5c29e04bb686df00dfff (patch)
treeea0337f1f162ec17daa60579f9087faedd12e0f6 /Cargo.toml
downloadcats-radio-node-96c6f2154007649c32fa5c29e04bb686df00dfff.tar.gz
cats-radio-node-96c6f2154007649c32fa5c29e04bb686df00dfff.tar.bz2
cats-radio-node-96c6f2154007649c32fa5c29e04bb686df00dfff.zip
Create scaffolding
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml23
1 files changed, 23 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..ace615e
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,23 @@
+[package]
+name = "cats-radio-node"
+version = "0.1.0"
+edition = "2021"
+authors = ["Matthias HB9EGM <hb9egm@mpb.li>"]
+license = "MIT"
+
+[dependencies]
+anyhow = "1.0"
+askama = { version = "0.12", features = ["with-axum"] }
+askama_axum = "0.4"
+axum = "0.7"
+simple_logger = "4.3"
+log = "0.4"
+serde = { version = "1.0", features = ["derive"] }
+serde_json = "1.0"
+toml = "0.8"
+sqlx = { version = "0.7", features = [ "runtime-tokio-rustls", "sqlite"]}
+tokio = { version = "1", features = ["full"] }
+tower-http = { version = "0.5.0", features = ["fs"] }
+
+# Websockets example in https://github.com/tokio-rs/axum/tree/main/examples/websockets
+# tokio-tungstenite = "0.21"