aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorMatthias P. Braendli <matthias.braendli@mpb.li>2024-01-14 19:06:28 +0100
committerMatthias P. Braendli <matthias.braendli@mpb.li>2024-01-14 19:06:28 +0100
commit6e5f5636a3d34d3edd5c901c8b67f6444a116ad5 (patch)
tree1ec1b2205a9b3b18c948c4fe4d14ce8438ec009f /Cargo.toml
parente8deeb539f8afc01f4936aa0d7eb1a29c4469da8 (diff)
downloadcats-radio-node-6e5f5636a3d34d3edd5c901c8b67f6444a116ad5.tar.gz
cats-radio-node-6e5f5636a3d34d3edd5c901c8b67f6444a116ad5.tar.bz2
cats-radio-node-6e5f5636a3d34d3edd5c901c8b67f6444a116ad5.zip
Add TUN functionality
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml4
1 files changed, 4 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 7706d87..23ccf35 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -18,6 +18,10 @@ sqlx = { version = "0.7", features = [ "runtime-tokio-rustls", "sqlite"]}
tokio = { version = "1", features = ["full"] }
tower-http = { version = "0.5.0", features = ["fs"] }
+futures-core = "0.3"
+futures= "0.3"
+tun = { version = "0.6", features = ["async"] }
+
ham-cats = { git = "https://gitlab.scd31.com/cats/ham-cats", rev = "d22f541c9a7e1c3a6c6e9449d87212b060f5edfb" }
half = { version = "2" }
rf4463 = { git = "https://gitlab.scd31.com/stephen/rf4463-lib", rev = "79c8def87540f8ab2663bfa3c9fb13db344ef84e" }