aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorMatthias P. Braendli <matthias.braendli@mpb.li>2024-01-14 11:04:52 +0100
committerMatthias P. Braendli <matthias.braendli@mpb.li>2024-01-14 11:04:52 +0100
commit1dedb0a5e36d3ac727cc2efdc4ff39c949823605 (patch)
treea9b5b3b54a1a0ae44142c46f06b045bfaff91463 /Cargo.toml
parentc8fe8be8c9f2e72fdb1259521e0b3ce0ca0324ee (diff)
downloadcats-radio-node-1dedb0a5e36d3ac727cc2efdc4ff39c949823605.tar.gz
cats-radio-node-1dedb0a5e36d3ac727cc2efdc4ff39c949823605.tar.bz2
cats-radio-node-1dedb0a5e36d3ac727cc2efdc4ff39c949823605.zip
Upgrade dependencies
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml8
1 files changed, 4 insertions, 4 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 048d13d..7706d87 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -18,12 +18,12 @@ sqlx = { version = "0.7", features = [ "runtime-tokio-rustls", "sqlite"]}
tokio = { version = "1", features = ["full"] }
tower-http = { version = "0.5.0", features = ["fs"] }
-ham-cats = { git = "https://gitlab.scd31.com/cats/ham-cats", commit = "d22f541c9a7e1c3a6c6e9449d87212b060f5edfb" }
+ham-cats = { git = "https://gitlab.scd31.com/cats/ham-cats", rev = "d22f541c9a7e1c3a6c6e9449d87212b060f5edfb" }
half = { version = "2" }
-rf4463 = { git = "https://gitlab.scd31.com/stephen/rf4463-lib", commit = "79c8def87540f8ab2663bfa3c9fb13db344ef84e" }
-rppal = { version = "0.14", features = ["hal"] }
+rf4463 = { git = "https://gitlab.scd31.com/stephen/rf4463-lib", rev = "79c8def87540f8ab2663bfa3c9fb13db344ef84e" }
+rppal = { version = "0.16", features = ["hal"] }
tonic = { version = "0.10", features = ["tls", "tls-roots"] }
-async-stream = "0.2"
+async-stream = "0.3"
rand = "0.8"
# Websockets example in https://github.com/tokio-rs/axum/tree/main/examples/websockets