aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorStefan Pöschel <github@basicmaster.de>2017-08-24 16:37:22 +0200
committerStefan Pöschel <github@basicmaster.de>2017-08-24 16:37:22 +0200
commit9e7695d9e9541a2e7243d6de0fb0eaa5ce38004d (patch)
treeb9ae820785968288b69f2c8e969cd45ecac62fe2 /Makefile.am
parent9f62da63eb7577d30dc67fc2823201b4f2598ffa (diff)
downloadODR-PadEnc-9e7695d9e9541a2e7243d6de0fb0eaa5ce38004d.tar.gz
ODR-PadEnc-9e7695d9e9541a2e7243d6de0fb0eaa5ce38004d.tar.bz2
ODR-PadEnc-9e7695d9e9541a2e7243d6de0fb0eaa5ce38004d.zip
Fix pedantic warnings and Makefile
- fix pedantic warnings (binary literals) - remove orphaned path from compiler call - add C++11 standard and `-Wpedantic` to compiler call
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 21c474c..e51392f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -7,7 +7,7 @@ else
GITVERSION_FLAGS =
endif
-odr_padenc_CXXFLAGS = $(GITVERSION_FLAGS) @MAGICKWAND_CFLAGS@ -Icontrib -Wall -Wextra
+odr_padenc_CXXFLAGS = $(GITVERSION_FLAGS) @MAGICKWAND_CFLAGS@ -std=c++11 -Wall -Wextra -Wpedantic
odr_padenc_LDADD = @MAGICKWAND_LDADD@
odr_padenc_SOURCES = \
src/odr-padenc.cpp \