aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorAnatol Pomazau <anatol@google.com>2012-04-06 11:04:36 -0700
committerAndroid (Google) Code Review <android-gerrit@google.com>2012-04-06 11:04:36 -0700
commit346629739680d9bf869dfaae2ddf2d7f4f4a9102 (patch)
tree83a022cf7eedab2d7d88763327329a46f8921caf /Makefile.am
downloadODR-PadEnc-346629739680d9bf869dfaae2ddf2d7f4f4a9102.tar.gz
ODR-PadEnc-346629739680d9bf869dfaae2ddf2d7f4f4a9102.tar.bz2
ODR-PadEnc-346629739680d9bf869dfaae2ddf2d7f4f4a9102.zip
Initial empty repository
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am29
1 files changed, 29 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..e2f6573
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,29 @@
+ACLOCAL_AMFLAGS = -I m4
+AUTOMAKE_OPTIONS = subdir-objects
+
+if IS_GIT_REPO
+GITVERSION_FLAGS = -DGITVERSION="\"`git describe --dirty`\""
+else
+GITVERSION_FLAGS =
+endif
+
+odr_padenc_CXXFLAGS = $(GITVERSION_FLAGS) @MAGICKWAND_CFLAGS@ -Icontrib -Wall -Wextra
+odr_padenc_LDADD = @MAGICKWAND_LDADD@
+odr_padenc_SOURCES = src/mot-encoder.cpp \
+ contrib/lib_crc.h \
+ contrib/lib_crc.c
+
+bin_PROGRAMS = odr-padenc$(EXEEXT)
+
+
+EXTRA_DIST = \
+ $(top_srcdir)/bootstrap \
+ $(top_srcdir)/README.md \
+ $(top_srcdir)/Doxyfile
+
+doc: export PROJECT_NUMBER:=$(shell git describe --dirty)
+
+.PHONY: doc
+doc:
+ doxygen
+