aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 3 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index fa51d65..b288218 100644
--- a/configure.ac
+++ b/configure.ac
@@ -16,16 +16,15 @@ LT_INIT
AX_CXX_COMPILE_STDCXX_11(noext,mandatory)
+# std::thread requires pthread
+AX_PTHREAD([], AC_MSG_ERROR([requires pthread]))
+
AC_CHECK_LIB([m], [sin])
AC_SEARCH_LIBS([init_rs_char], [fec], [], [
AC_MSG_ERROR([unable to find libfec])
])
-AX_BOOST_BASE([1.41.0], [], AC_MSG_ERROR([BOOST 1.41 or later is required]))
-AC_CHECK_LIB([boost_system], [main], [], [AC_MSG_ERROR([library boost_system is missing])])
-AC_CHECK_LIB([boost_thread], [main], [], [AC_MSG_ERROR([library boost_thread is missing])])
-
AC_CHECK_LIB([rt], [clock_gettime], [], [AC_MSG_ERROR([library rt is missing])])
AM_PATH_ALSA(1.0.25)