aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthias P. Braendli <matthias.braendli@mpb.li>2013-12-15 15:49:17 +0100
committerMatthias P. Braendli <matthias.braendli@mpb.li>2013-12-15 15:49:17 +0100
commitd52cf07f7855c402d3d317e94b219f6ef34fe803 (patch)
tree5daebcf60d7a438fb9e7ee2e6c4266f0d2ca7430 /configure.ac
parent8ef2e966cc8e07bb1d0c242070f7226e42776605 (diff)
downloadODR-AudioEnc-d52cf07f7855c402d3d317e94b219f6ef34fe803.tar.gz
ODR-AudioEnc-d52cf07f7855c402d3d317e94b219f6ef34fe803.tar.bz2
ODR-AudioEnc-d52cf07f7855c402d3d317e94b219f6ef34fe803.zip
Add aac-enc-dabplus-zmq with ZeroMQ output
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 487fd8d..04252ce 100644
--- a/configure.ac
+++ b/configure.ac
@@ -24,6 +24,16 @@ LT_INIT
AC_CHECK_LIB([m], [sin])
+# fdk-aac-dabplus-zmq needs ZeroMQ
+AC_ARG_ENABLE([zmq],
+ [AS_HELP_STRING([--enable-zmq], [Enable fdk-aac-dabplus-zmq with ZeroMQ output])]
+ )
+
+AS_IF(test "x$enable_zmq" = "xyes",
+ AC_CHECK_LIB(zmq, zmq_init, , AC_MSG_ERROR(ZeroMQ libzmq is required)))
+
+AM_CONDITIONAL(HAVE_ZEROMQ_TEST, test "x$enable_zmq" = "xyes")
+
dnl soname version to use
dnl goes by ‘current[:revision[:age]]’ with the soname ending up as
dnl current.age.revision