aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthias P. Braendli <matthias.braendli@mpb.li>2015-03-11 21:15:38 +0100
committerMatthias P. Braendli <matthias.braendli@mpb.li>2015-03-11 21:15:38 +0100
commit58378f49c75b7c6e184c499082328761b468da68 (patch)
treedf16e70225672ea19fb1df01f2af40aaae67dfaa /configure.ac
parent599d0fc5892725e471772e567555bf075ad2ae86 (diff)
downloadODR-AudioEnc-58378f49c75b7c6e184c499082328761b468da68.tar.gz
ODR-AudioEnc-58378f49c75b7c6e184c499082328761b468da68.tar.bz2
ODR-AudioEnc-58378f49c75b7c6e184c499082328761b468da68.zip
Add libvlc input
Be careful about sample rate conversion, VLC only wants to use the ugly resampler on some machines.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1220cfe..d0b4371 100644
--- a/configure.ac
+++ b/configure.ac
@@ -28,12 +28,24 @@ AM_PATH_ALSA(1.0.25)
AC_ARG_ENABLE([jack],
AS_HELP_STRING([--enable-jack], [Enable JACK input]))
+AC_ARG_ENABLE([vlc],
+ AS_HELP_STRING([--enable-vlc], [Enable libvlc input]))
+
AS_IF([test "x$enable_jack" = "xyes"],
AC_CHECK_LIB(jack, jack_client_open, [],
[AC_MSG_ERROR([JACK is required])]))
AS_IF([test "x$enable_jack" = "xyes"],
AC_DEFINE(HAVE_JACK, [1], [Define if JACK input is enabled]))
+AS_IF([test "x$enable_vlc" = "xyes"], [
+ PKG_CHECK_MODULES([LIBVLC], [libvlc])
+ AC_SUBST([LIBVLC_CFLAGS])
+ AC_SUBST([LIBVLC_LIBS]) ] )
+
+AS_IF([test "x$enable_vlc" = "xyes"],
+ AC_DEFINE(HAVE_VLC, [1], [Define if VLC input is enabled]))
+
+
# Link against jack
AM_CONDITIONAL([HAVE_JACK], [ test "x$enable_jack" = "xyes" ])
@@ -49,6 +61,7 @@ else
AC_MSG_ERROR(MagickWand not found)
fi
+
dnl soname version to use
dnl goes by ‘current[:revision[:age]]’ with the soname ending up as
dnl current.age.revision