aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMatthias P. Braendli <matthias.braendli@mpb.li>2014-04-25 17:32:03 +0200
committerMatthias P. Braendli <matthias.braendli@mpb.li>2014-04-25 17:32:03 +0200
commita8bd9b19bba683031f6c7a68e9e6ca653be18d6c (patch)
treedfa89c850438c59cce40897a29287eeb1978f31b /Makefile.am
parent8f13b3f2580f182f51d9ad131da1deafdcd5e91a (diff)
downloadODR-AudioEnc-a8bd9b19bba683031f6c7a68e9e6ca653be18d6c.tar.gz
ODR-AudioEnc-a8bd9b19bba683031f6c7a68e9e6ca653be18d6c.tar.bz2
ODR-AudioEnc-a8bd9b19bba683031f6c7a68e9e6ca653be18d6c.zip
merge file and alsa encoders into dabplus-enc
There was a lot of redundant code between the two
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am42
1 files changed, 16 insertions, 26 deletions
diff --git a/Makefile.am b/Makefile.am
index 7801cc1..8662153 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -43,31 +43,22 @@ libfdk_aac_la_LDFLAGS = -version-info @FDK_AAC_VERSION@ -no-undefined \
#aac_enc_SOURCES = src/aac-enc.c \
# src/wavreader.c
-dabplus_enc_file_zmq_LDADD = libfdk-aac.la -lfec -lzmq
-dabplus_enc_file_zmq_CFLAGS = $(AM_CPPFLAGS) $(GITVERSION_FLAGS)
-dabplus_enc_file_zmq_SOURCES = src/dabplus-enc-file-zmq.c \
- src/wavreader.c \
- src/encryption.c \
- src/encryption.h \
- src/utils.c \
- src/utils.h \
- contrib/lib_crc.h \
- contrib/lib_crc.c
-
-dabplus_enc_alsa_zmq_LDFLAGS = -no-install
-dabplus_enc_alsa_zmq_LDADD = libfdk-aac.la -lfec -lzmq -lasound \
+dabplus_enc_LDFLAGS = -no-install
+dabplus_enc_LDADD = libfdk-aac.la -lfec -lzmq -lasound \
-lrt -lboost_thread
-dabplus_enc_alsa_zmq_CPPFLAGS = $(AM_CPPFLAGS) $(GITVERSION_FLAGS)
-dabplus_enc_alsa_zmq_SOURCES = src/dabplus-enc-alsa-zmq.cpp \
- src/AlsaInput.cpp \
- src/AlsaInput.h \
- src/SampleQueue.h \
- src/encryption.c \
- src/encryption.h \
- src/zmq.hpp \
- src/utils.c \
- src/utils.h
-
+dabplus_enc_CPPFLAGS = $(AM_CPPFLAGS) $(GITVERSION_FLAGS)
+dabplus_enc_SOURCES = src/dabplus-enc.cpp \
+ src/FileInput.cpp \
+ src/FileInput.h \
+ src/AlsaInput.cpp \
+ src/AlsaInput.h \
+ src/SampleQueue.h \
+ src/encryption.c \
+ src/encryption.h \
+ src/zmq.hpp \
+ src/utils.c \
+ src/utils.h \
+ src/wavreader.c
mot_encoder_CFLAGS = $(GITVERSION_FLAGS) @MAGICKWAND_CFLAGS@ -Icontrib
mot_encoder_LDADD = @MAGICKWAND_LDADD@
@@ -75,8 +66,7 @@ mot_encoder_SOURCES = src/mot-encoder.c \
contrib/lib_crc.h \
contrib/lib_crc.c
-bin_PROGRAMS = dabplus-enc-file-zmq$(EXEEXT) \
- dabplus-enc-alsa-zmq$(EXEEXT) \
+bin_PROGRAMS = dabplus-enc$(EXEEXT) \
mot-encoder$(EXEEXT)
noinst_HEADERS = src/wavreader.h