aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMatthias P. Braendli <matthias.braendli@mpb.li>2019-11-11 11:38:02 +0100
committerMatthias P. Braendli <matthias.braendli@mpb.li>2019-11-11 11:38:02 +0100
commit0e5af65c467b2423a0b857ae3ad98c91acc1e190 (patch)
treed07f69550d8886271e44fe79c4dcfb299cafbd38 /Makefile.am
parentefe406d9724f959c8bc2a31802559ca6d41fd897 (diff)
downloadODR-AudioEnc-0e5af65c467b2423a0b857ae3ad98c91acc1e190.tar.gz
ODR-AudioEnc-0e5af65c467b2423a0b857ae3ad98c91acc1e190.tar.bz2
ODR-AudioEnc-0e5af65c467b2423a0b857ae3ad98c91acc1e190.zip
Include patched FDK-AAC in the repository
The initial idea was to get the DAB+ patch into upstream, but since that follows the android source releases, there is no place for a custom DAB+ patch there. So instead of having to maintain a patched fdk-aac that has to have the same .so version as the distribution package on which it is installed, we prefer having a separate fdk-aac-dab library to avoid collision. At that point, there's no reason to keep fdk-aac in a separate repository, as odr-audioenc is the only tool that needs DAB+ encoding support. Including it here simplifies installation, and makes it consistent with toolame-dab, also shipped in this repository. DAB+ decoding support (needed by ODR-SourceCompanion, dablin, etisnoop, welle.io and others) can be done using upstream FDK-AAC.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 9 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 66de262..176439b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,6 +1,8 @@
ACLOCAL_AMFLAGS = -I m4
AUTOMAKE_OPTIONS = subdir-objects
+SUBDIRS = fdk-aac
+
if IS_GIT_REPO
GITVERSION_FLAGS = -DGITVERSION="\"`git describe --dirty`\""
else
@@ -74,12 +76,16 @@ FEC_SOURCES = contrib/fec/char.h \
odr_audioenc_LDFLAGS = -no-install
odr_audioenc_LDADD = libtoolame-dab.la \
+ fdk-aac/libfdk-aac-dab.la \
-lzmq \
$(odr_audioenc_LDADD_JACK) \
$(odr_audioenc_LDADD_ALSA) \
- $(LIBVLC_LIBS) $(LIBFDKAAC_LIBS)
-odr_audioenc_CXXFLAGS = $(LIBFDKAAC_CFLAGS) $(GITVERSION_FLAGS) \
- -Wall -ggdb -O2 -Isrc -Icontrib
+ $(LIBVLC_LIBS)
+odr_audioenc_CXXFLAGS = $(GITVERSION_FLAGS) \
+ -Wall -ggdb -O2 -Isrc -Icontrib \
+ -Ifdk-aac/libSYS/include/ \
+ -Ifdk-aac/libAACenc/include/ \
+ -Ifdk-aac/libAACdec/include/
odr_audioenc_SOURCES = src/odr-audioenc.cpp \
src/FileInput.cpp \