summaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am22
1 files changed, 15 insertions, 7 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 31deb7391..bd32206bf 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -6,17 +6,25 @@ include $(top_srcdir)/Makefile.common
SUBDIRS =
-AM_CPPFLAGS = $(GENERAL_CPPFLAGS)
+if HAVE_CPPUNIT
+
+AM_CPPFLAGS = \
+ $(GENERAL_CPPFLAGS) \
+ $(CPPUNIT_CFLAGS)
LDADD = \
$(GENERAL_LDDFLAGS) \
- $(USRP_UHD_LA)
+ $(USRP_UHD_LA) \
+ $(CPPUNIT_LIBS)
-noinst_PROGRAMS = \
- addr_test \
- wax_test
+noinst_PROGRAMS = cppunit_test
-addr_test_SOURCES = addr_test.cpp
-wax_test_SOURCES = wax_test.cpp
+cppunit_test_SOURCES = \
+ cppunit_test.cpp \
+ addr_test.cpp \
+ usrp_dboard_test.cpp \
+ wax_test.cpp
TESTS = $(noinst_PROGRAMS)
+
+endif