aboutsummaryrefslogtreecommitdiffstats
path: root/mpm/tests/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'mpm/tests/CMakeLists.txt')
-rw-r--r--mpm/tests/CMakeLists.txt24
1 files changed, 24 insertions, 0 deletions
diff --git a/mpm/tests/CMakeLists.txt b/mpm/tests/CMakeLists.txt
new file mode 100644
index 000000000..4139f3c59
--- /dev/null
+++ b/mpm/tests/CMakeLists.txt
@@ -0,0 +1,24 @@
+#
+# Copyright 2017 Ettus Research (National Instruments)
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+
+########################################################################
+# This file included, use CMake directory variables
+########################################################################
+
+
+USRP_PERIPHS_ADD_OBJECT(tests
+ ${CMAKE_CURRENT_SOURCE_DIR}/tests_spi_iface.cpp)