aboutsummaryrefslogtreecommitdiffstats
path: root/mpm/n310/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'mpm/n310/CMakeLists.txt')
-rw-r--r--mpm/n310/CMakeLists.txt26
1 files changed, 26 insertions, 0 deletions
diff --git a/mpm/n310/CMakeLists.txt b/mpm/n310/CMakeLists.txt
new file mode 100644
index 000000000..3177dd5b5
--- /dev/null
+++ b/mpm/n310/CMakeLists.txt
@@ -0,0 +1,26 @@
+#
+# Copyright 2017 Ettus Research (National Instruments)
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+
+########################################################################
+# This file included, use CMake directory variables
+########################################################################
+
+
+USRP_PERIPHS_ADD_OBJECT(n310
+ ${CMAKE_CURRENT_SOURCE_DIR}/periph_manager.cpp)
+
+TARGET_INCLUDE_DIRECTORIES(n310 PUBLIC ${UHD_HOST_ROOT}/lib/usrp/common)