aboutsummaryrefslogtreecommitdiffstats
path: root/lib/usrp/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/usrp/CMakeLists.txt')
-rw-r--r--lib/usrp/CMakeLists.txt27
1 files changed, 27 insertions, 0 deletions
diff --git a/lib/usrp/CMakeLists.txt b/lib/usrp/CMakeLists.txt
new file mode 100644
index 000000000..2f96fd349
--- /dev/null
+++ b/lib/usrp/CMakeLists.txt
@@ -0,0 +1,27 @@
+#
+# Copyright 2010 Ettus Research LLC
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+
+
+ADD_SUBDIRECTORY(dboard)
+ADD_SUBDIRECTORY(mboard)
+
+ADD_LIBRARY(uhd_usrp STATIC
+ usrp.cpp
+)
+
+TARGET_LINK_LIBRARIES(uhd_usrp uhd_usrp_dboard)
+TARGET_LINK_LIBRARIES(uhd_usrp uhd_usrp_mboard)