summaryrefslogtreecommitdiffstats
path: root/include/uhd/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'include/uhd/Makefile.am')
-rw-r--r--include/uhd/Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/include/uhd/Makefile.am b/include/uhd/Makefile.am
new file mode 100644
index 000000000..00691d920
--- /dev/null
+++ b/include/uhd/Makefile.am
@@ -0,0 +1,30 @@
+#
+# Copyright 2010 Ettus Research LLC
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+
+include $(top_srcdir)/Makefile.common
+
+SUBDIRS = usrp quadradio
+
+this_includedir = $(includedir)/uhd
+this_include_HEADERS = \
+ device.hpp \
+ device_addr.hpp \
+ gain_handler.hpp \
+ props.hpp \
+ time_spec.hpp \
+ utils.hpp \
+ wax.hpp