aboutsummaryrefslogtreecommitdiffstats
path: root/host/utils/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'host/utils/CMakeLists.txt')
-rw-r--r--host/utils/CMakeLists.txt24
1 files changed, 24 insertions, 0 deletions
diff --git a/host/utils/CMakeLists.txt b/host/utils/CMakeLists.txt
index a95864ca7..280c8dfaa 100644
--- a/host/utils/CMakeLists.txt
+++ b/host/utils/CMakeLists.txt
@@ -24,9 +24,33 @@ TARGET_LINK_LIBRARIES(uhd_find_devices uhd)
ADD_EXECUTABLE(uhd_usrp_probe uhd_usrp_probe.cpp)
TARGET_LINK_LIBRARIES(uhd_usrp_probe uhd)
+ADD_EXECUTABLE(fpga-downloader fpga-downloader.cpp)
+TARGET_LINK_LIBRARIES(fpga-downloader)
+
+ADD_EXECUTABLE(clkgen-config clkgen-config.cpp)
+TARGET_LINK_LIBRARIES(clkgen-config)
+
+ADD_EXECUTABLE(usrp-e-loopback usrp-e-loopback.c)
+TARGET_LINK_LIBRARIES(usrp-e-loopback pthread)
+
+ADD_EXECUTABLE(usrp-e-debug-pins usrp-e-debug-pins.c)
+TARGET_LINK_LIBRARIES(usrp-e-debug-pins)
+
+ADD_EXECUTABLE(usrp-e-i2c usrp-e-i2c.c)
+TARGET_LINK_LIBRARIES(usrp-e-i2c)
+
+ADD_EXECUTABLE(usrp-e-spi usrp-e-spi.c)
+TARGET_LINK_LIBRARIES(usrp-e-spi)
+
INSTALL(TARGETS
uhd_find_devices
uhd_usrp_probe
+ fpga-downloader
+ usrp-e-loopback
+ usrp-e-debug-pins
+ usrp-e-spi
+ usrp-e-i2c
+ clkgen-config
RUNTIME DESTINATION ${RUNTIME_DIR}
)