aboutsummaryrefslogtreecommitdiffstats
path: root/host/utils/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'host/utils/CMakeLists.txt')
-rw-r--r--host/utils/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/host/utils/CMakeLists.txt b/host/utils/CMakeLists.txt
index 11bb2488a..f693ee7a6 100644
--- a/host/utils/CMakeLists.txt
+++ b/host/utils/CMakeLists.txt
@@ -35,6 +35,13 @@ SET(x3xx_burner_sources
cdecode.c
)
+find_package(UDev)
+IF(ENABLE_E300)
+ IF(UDEV_FOUND)
+ LIST(APPEND util_runtime_sources usrp_e3x0_network_mode.cpp)
+ ENDIF(UDEV_FOUND)
+ENDIF(ENABLE_E300)
+
#for each source: build an executable and install
FOREACH(util_source ${util_runtime_sources})
GET_FILENAME_COMPONENT(util_name ${util_source} NAME_WE)