aboutsummaryrefslogtreecommitdiffstats
path: root/host/tests/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'host/tests/CMakeLists.txt')
-rw-r--r--host/tests/CMakeLists.txt14
1 files changed, 13 insertions, 1 deletions
diff --git a/host/tests/CMakeLists.txt b/host/tests/CMakeLists.txt
index 551b57bb9..f31daed50 100644
--- a/host/tests/CMakeLists.txt
+++ b/host/tests/CMakeLists.txt
@@ -52,7 +52,6 @@ set(test_sources
vrt_test.cpp
expert_test.cpp
fe_conn_test.cpp
- rfnoc_chdr_test.cpp
rfnoc_node_test.cpp
)
@@ -191,6 +190,19 @@ UHD_ADD_NONAPI_TEST(
EXTRA_SOURCES ${CMAKE_SOURCE_DIR}/lib/utils/config_parser.cpp
)
+include_directories(${CMAKE_BINARY_DIR}/lib/rfnoc/chdr/)
+include_directories(${CMAKE_SOURCE_DIR}/lib/rfnoc/chdr/)
+add_executable(rfnoc_chdr_test
+ rfnoc_chdr_test.cpp
+ ${CMAKE_SOURCE_DIR}/lib/rfnoc/chdr/chdr_types.cpp
+ ${CMAKE_SOURCE_DIR}/lib/rfnoc/chdr/chdr_packet.cpp
+)
+target_link_libraries(rfnoc_chdr_test uhd ${Boost_LIBRARIES})
+UHD_ADD_TEST(rfnoc_chdr_test rfnoc_chdr_test)
+UHD_INSTALL(TARGETS rfnoc_chdr_test RUNTIME DESTINATION ${PKG_LIB_DIR}/tests COMPONENT tests)
+
+
+
# Careful: This is to satisfy the out-of-library build of paths.cpp. This is
# duplicate code from lib/utils/CMakeLists.txt, and it's been simplified.
# TODO Figure out if this is even needed