aboutsummaryrefslogtreecommitdiffstats
path: root/host/tests/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'host/tests/CMakeLists.txt')
-rw-r--r--host/tests/CMakeLists.txt6
1 files changed, 1 insertions, 5 deletions
diff --git a/host/tests/CMakeLists.txt b/host/tests/CMakeLists.txt
index 596ab1017..1fb1a1951 100644
--- a/host/tests/CMakeLists.txt
+++ b/host/tests/CMakeLists.txt
@@ -48,11 +48,7 @@ SET(test_sources
)
#turn each test cpp file into an executable with an int main() function
-IF(MINGW)
- ADD_DEFINITIONS(-DBOOST_TEST_MAIN)
-ELSE()
- ADD_DEFINITIONS(-DBOOST_TEST_DYN_LINK -DBOOST_TEST_MAIN)
-ENDIF()
+ADD_DEFINITIONS(-DBOOST_TEST_DYN_LINK -DBOOST_TEST_MAIN)
SET(UHD_TEST_TARGET_DEPS uhd)
SET(UHD_TEST_LIBRARY_DIRS ${Boost_LIBRARY_DIRS})