aboutsummaryrefslogtreecommitdiffstats
path: root/host/tests/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'host/tests/CMakeLists.txt')
-rw-r--r--host/tests/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/host/tests/CMakeLists.txt b/host/tests/CMakeLists.txt
index 1711d0ab2..9eb48eedb 100644
--- a/host/tests/CMakeLists.txt
+++ b/host/tests/CMakeLists.txt
@@ -106,6 +106,20 @@ foreach(benchmark_source ${benchmark_sources})
endforeach(benchmark_source)
# Other tests that don't directly link with libuhd: (TODO find a nicer way to do this)
+if(ENABLE_DPDK)
+ include_directories(${CMAKE_BINARY_DIR}/lib/transport/)
+ include_directories(${CMAKE_SOURCE_DIR}/lib/transport/)
+ find_package(DPDK)
+ include_directories(${DPDK_INCLUDE_DIR})
+ add_executable(dpdk_test
+ dpdk_test.cpp
+ ${CMAKE_SOURCE_DIR}/lib/transport/dpdk_zero_copy.cpp
+ )
+ target_link_libraries(dpdk_test uhd ${Boost_LIBRARIES} ${DPDK_LIBRARIES})
+ # For the DPDK test, don't automatically run (requires specific config)
+ UHD_INSTALL(TARGETS dpdk_test RUNTIME DESTINATION ${PKG_LIB_DIR}/tests COMPONENT tests)
+ENDIF(ENABLE_DPDK)
+
include_directories(${CMAKE_BINARY_DIR}/lib/rfnoc/nocscript/)
include_directories(${CMAKE_SOURCE_DIR}/lib/rfnoc/nocscript/)
add_executable(nocscript_expr_test