aboutsummaryrefslogtreecommitdiffstats
path: root/host/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'host/test/CMakeLists.txt')
-rw-r--r--host/test/CMakeLists.txt11
1 files changed, 8 insertions, 3 deletions
diff --git a/host/test/CMakeLists.txt b/host/test/CMakeLists.txt
index b1d5924c7..1791d9082 100644
--- a/host/test/CMakeLists.txt
+++ b/host/test/CMakeLists.txt
@@ -15,7 +15,9 @@
# along with this program. If not, see <http://www.gnu.org/licenses/>.
#
-
+########################################################################
+# unit test suite
+########################################################################
ADD_EXECUTABLE(main_test
main_test.cpp
addr_test.cpp
@@ -23,7 +25,10 @@ ADD_EXECUTABLE(main_test
vrt_test.cpp
wax_test.cpp
)
-
TARGET_LINK_LIBRARIES(main_test uhd)
-
ADD_TEST(test main_test)
+
+########################################################################
+# demo of a loadable module
+########################################################################
+ADD_LIBRARY(module_test MODULE module_test.cpp)