aboutsummaryrefslogtreecommitdiffstats
path: root/host/lib/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'host/lib/CMakeLists.txt')
-rw-r--r--host/lib/CMakeLists.txt34
1 files changed, 34 insertions, 0 deletions
diff --git a/host/lib/CMakeLists.txt b/host/lib/CMakeLists.txt
index 5252eda8f..48fee5a80 100644
--- a/host/lib/CMakeLists.txt
+++ b/host/lib/CMakeLists.txt
@@ -149,6 +149,40 @@ LIST(APPEND libuhd_sources
)
########################################################################
+# Conditionally add the usrp1e sources
+########################################################################
+MESSAGE(STATUS "Configuring usrp-e support...")
+
+INCLUDE(CheckIncludeFiles)
+SET(usrp_e_required_headers
+ linux/ioctl.h
+ linux/spi/spidev.h
+ linux/usrp_e.h
+)
+CHECK_INCLUDE_FILES(
+ "${usrp_e_required_headers}"
+ HAVE_USRP_E_REQUIRED_HEADERS
+)
+
+IF(HAVE_USRP_E_REQUIRED_HEADERS)
+ MESSAGE(STATUS " Building usrp-e support.")
+ LIST(APPEND libuhd_sources
+ usrp/usrp_e/dboard_impl.cpp
+ usrp/usrp_e/dboard_iface.cpp
+ usrp/usrp_e/dsp_impl.cpp
+ usrp/usrp_e/fpga-downloader.cc
+ usrp/usrp_e/mboard_impl.cpp
+ usrp/usrp_e/usrp_e_impl.cpp
+ usrp/usrp_e/usrp_e_iface.cpp
+ )
+ELSE(HAVE_USRP_E_REQUIRED_HEADERS)
+ MESSAGE(STATUS " Skipping usrp-e support.")
+ LIST(APPEND libuhd_sources
+ usrp/usrp_e/usrp_e_none.cpp
+ )
+ENDIF(HAVE_USRP_E_REQUIRED_HEADERS)
+
+########################################################################
# Setup defines for module loading
########################################################################
MESSAGE(STATUS "Configuring module loading...")