aboutsummaryrefslogtreecommitdiffstats
path: root/host/lib/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'host/lib/CMakeLists.txt')
-rw-r--r--host/lib/CMakeLists.txt27
1 files changed, 25 insertions, 2 deletions
diff --git a/host/lib/CMakeLists.txt b/host/lib/CMakeLists.txt
index 22fbde265..a7dded86b 100644
--- a/host/lib/CMakeLists.txt
+++ b/host/lib/CMakeLists.txt
@@ -52,10 +52,33 @@ LIST(APPEND libuhd_sources
########################################################################
# Conditionally add the usrp1e sources
########################################################################
-LIST(APPEND libuhd_sources
- usrp/usrp1e/usrp1e_none.cpp
+INCLUDE(CheckIncludeFiles)
+SET(usrp1e_required_headers
+ linux/ioctl.h
+ linux/spi/spidev.h
+)
+CHECK_INCLUDE_FILES(
+ "${usrp1e_required_headers}"
+ HAS_USRP1E_REQUIRED_HEADERS
)
+IF(HAS_USRP1E_REQUIRED_HEADERS)
+ MESSAGE(STATUS "Building usrp1e support...")
+ LIST(APPEND libuhd_sources
+ usrp/usrp1e/dboard_impl.cpp
+ usrp/usrp1e/dboard_interface.cpp
+ usrp/usrp1e/dsp_impl.cpp
+ usrp/usrp1e/fpga-downloader.cc
+ usrp/usrp1e/mboard_impl.cpp
+ usrp/usrp1e/usrp1e_impl.cpp
+ )
+ELSE(HAS_USRP1E_REQUIRED_HEADERS)
+ MESSAGE(STATUS "Skipping usrp1e support...")
+ LIST(APPEND libuhd_sources
+ usrp/usrp1e/usrp1e_none.cpp
+ )
+ENDIF(HAS_USRP1E_REQUIRED_HEADERS)
+
########################################################################
# Setup defines for module loading
########################################################################