aboutsummaryrefslogtreecommitdiffstats
path: root/host/lib/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'host/lib/CMakeLists.txt')
-rw-r--r--host/lib/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/host/lib/CMakeLists.txt b/host/lib/CMakeLists.txt
index 7a76ebd53..d8ff66a96 100644
--- a/host/lib/CMakeLists.txt
+++ b/host/lib/CMakeLists.txt
@@ -94,6 +94,18 @@ LIBUHD_APPEND_SOURCES(
)
########################################################################
+# Add DLL resource file to Windows build
+########################################################################
+IF(MSVC)
+ CONFIGURE_FILE(
+ ${CMAKE_CURRENT_SOURCE_DIR}/uhd.rc.in
+ ${CMAKE_CURRENT_BINARY_DIR}/uhd.rc
+ @ONLY)
+
+ LIST(APPEND libuhd_sources ${CMAKE_CURRENT_BINARY_DIR}/uhd.rc)
+ENDIF(MSVC)
+
+########################################################################
# Setup libuhd library
########################################################################
ADD_LIBRARY(uhd SHARED ${libuhd_sources})