aboutsummaryrefslogtreecommitdiffstats
path: root/host/include/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'host/include/CMakeLists.txt')
-rw-r--r--host/include/CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/host/include/CMakeLists.txt b/host/include/CMakeLists.txt
index 0efed9785..f46870dc2 100644
--- a/host/include/CMakeLists.txt
+++ b/host/include/CMakeLists.txt
@@ -5,16 +5,16 @@
# SPDX-License-Identifier: GPL-3.0
#
-CONFIGURE_FILE(
+configure_file(
${CMAKE_CURRENT_SOURCE_DIR}/config.h.in
${CMAKE_CURRENT_BINARY_DIR}/config.h
)
-IF(ENABLE_C_API)
+if(ENABLE_C_API)
UHD_INSTALL(FILES ${CMAKE_CURRENT_SOURCE_DIR}/uhd.h
DESTINATION ${INCLUDE_DIR}
COMPONENT headers
)
-ENDIF(ENABLE_C_API)
+endif(ENABLE_C_API)
-ADD_SUBDIRECTORY(uhd)
+add_subdirectory(uhd)